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http://www.broadinstitute.org/igv 

65,000 registrations 

Desktop application for the interactive 
visual exploration of integrated genomic datasets 
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With IGV you can… 

•  Explore large genomic datasets with an 
intuitive, easy-to-use interface. 

•  Integrate multiple data types with clinical 
and other sample information. 

•  View data from multiple sources: 
- local, remote, and “cloud-based”. 

Features 
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TCGA 

Local files 

HTTP server 

FTP server 

GenomeSpace 

- View local files without uploading. 
- View remote files without downloading the whole dataset. 

IGV data sources 
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Using IGV: The Basics 
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•  Launch IGV 
•  Select a reference genome 
•  Load data 
•  Navigate through the data 

Using IGV: the basics 
Hands-on exercise 
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Launch IGV 
http://www.broadinstitute.org/igv 



The Broad Institute of MIT and Harvard 
The Broad Institute of MIT and Harvard 

The Broad Institute of MIT and Harvard 

Launch IGV 
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Launch IGV 
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Launch IGV 
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Select the reference genome 

Select genome from 
the drop-down menu 
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Select the reference genome 

Today, we will use both 
Human hg18 and hg19  

If Human hg19 is not in the menu, 
then click on More…  
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Select the reference genome 

Select Human hg19 
from the list of genomes, 
and click OK 
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Select the reference genome 
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Select the reference genome 

Select Human hg18 
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Load data 

Select File > Load from Server…  
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Load data 

Open the  
Tutorials menu 

Select  
UI Basics (Encode) 
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Screen layout 
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Screen layout 

Click the Home button 
for whole-genome view 
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Screen layout 

tracks 
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toolbar 
menus 

genome 
ruler 

data 
panel 

genome 
features 

Screen layout 

tracks 
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File formats and track types 
•  The file format defines the track type. 
•  The track type determines the display options 
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File formats and track types 
•  The file format defines the track type. 
•  The track type determines the display options 

•  IGV supports many different file formats.  

 

•  For current list see: www.broadinstitute.org/igv/FileFormats 
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Navigate 

Click on the 1 in the 
genome ruler to 
view chromosome 1 
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Navigate 
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Navigate 

Click and drag  
from 40 mb to 60 mb 
on the genomic ruler 
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Navigate 
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Navigate 

Double-click to 
zoom in for closer 
view of peak 
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Navigate 
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Navigate 

Click anywhere 
in the data panel 
and drag tracks 
left and right 
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Navigate 

Type gene name or other RefSeq 
annotation into the Search Box 
and click Go 
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Navigate 

Type gene name or other RefSeq 
annotation into the Search Box 
and click Go 
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Navigate 
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Navigate 

Click on the last tick on the 
“railroad track” to zoom in 
to maximum resolution 
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Navigate 

Maximum zoom. 
We’ve moved from 
whole genome to 
base pair resolution Reference 

sequence 
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Reference sequence 

By default the sequence for the forward strand is shown. 

Click anywhere on the sequence to see a 3 frame translation. 

Click the arrow on the left to reverse the strand. 
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Genome annotation track 

3’ UTR 5’ UTR Exons Intron 

UCSC style gene representation 

Zoomed in views 

Zoomed out views 
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Annotation display mode 

1. Features are drawn in a single row, by default   

2. Expand the track using the popup menu 
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Annotation display mode 

3. For a compact view of all variants use “Squished” 
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Viewing multiple regions 
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Viewing multiple regions 
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Viewing multiple regions 

•  Search box 
Enter multiple loci or features in the search box 

 
 

•  Regions > Gene Lists… 
Select from a number of pre-defined gene lists, or 
Create your own persistent list 
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Viewing multiple regions 
To go back to the standard, single-region view: 

•  double-click on a region label  – or – 
•  right-click and select “Switch to standard view” 
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Viewing NGS Data 
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Viewing alignments 
Whole chromosome view 
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Zoom in to view alignments 

Viewing alignments 
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Viewing alignments 
Coverage track now has more detail 
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Viewing alignments 

Bases that do not match the 
reference sequence are 

highlighted by color 

Zoom in to see more detail 
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Viewing alignments 
Zoom in to see more detail 
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Viewing alignments 

Low-quality base 
calls are faint, 

semi-transparent. 

Zoom in to see more detail 
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Viewing alignments 

How far do you need to        
zoom in to see the alignments? 
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Viewing alignments 

How far do you need to        
zoom in to see the alignments? 

30 kb or set a different threshold 
in preferences 

 
•  Higher value (larger region) è requires more memory  
•  Low coverage files è ok to use higher value    
•  Very deep coverage files è use lower value 
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Downsampling: 
•  limits displayed read depth 
•  uses less memory 

Viewing alignments 
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•  Load alignments from whole genome sequencing 
•  View sites where SNPs were called 
•  Sort and color to highlight patterns 

Viewing SNPs 
Hands-on exercise 
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Viewing SNPs 

Before we start: 
Select File > New Session 
to clear IGV window 
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Viewing SNPs 

Select File > Load from Server…  
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Viewing SNPs 

Open the  
Tutorials menu 

Select  
SNP Validation 

Select File > Load from Server…  
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Viewing SNPs 

Type “snp1” in the Search Box 
and click Go 
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Viewing SNPs 
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Viewing SNPs 

If necessary, click and drag 
the window divider for a 
larger data panel 
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Viewing SNPs 
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Viewing SNPs 

Click on yellow balloon icon 
in the toolbar to modify the 
information popup behavior 
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Viewing SNPs 

Click & drag to 
position mismatched 
bases between the 
center guidelines 
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Viewing SNPs 

Right-click on alignments and select 
Sort alignments by > base 

On Mac: Right-click = ⌘-click 
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Viewing SNPs 
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Viewing SNPs 

Mouse over red & blue bar in coverage track. 
Note allele counts and frequencies.  
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Viewing SNPs 

Type “snp2” in the Search Box 
and click Go 

Note: 
Large % of low quality base calls,  
and scatter of “C” mismatches 
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Viewing SNPs 

Click & drag to 
position locus with 
5 blue C’s between 
center guidelines 
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Viewing SNPs 

Right-click on alignments and select 
Shade base by quality 
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Viewing SNPs 
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Viewing SNPs 

Right-click on alignments and select 
Sort alignments by > read strand 
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Viewing SNPs 

Right-click on alignments and select 
Color alignments by > read strand 
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Viewing SNPs 
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Viewing Structural Events 
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Structural events 
 
 

•  Paired reads can yield evidence for genomic “structural 
events”, such as deletions, translocations, and inversions.  

•  Alignment coloring options help highlight these events 
based on: 

 
•  Inferred insert size (template length) 

•  Pair orientation (relative strand of pair) 
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Paired-end sequencing 
 
 

Read from 
each end 

Fragment 

DNA or 
cDNA 

insert size 
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Paired-end sequencing 
 
 

inferred insert size 

Align to 
Reference 

Read from 
each end 

Fragment 

DNA or 
cDNA 

insert size 
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Interpreting Insert Size 
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Interpreting inferred insert size 

The “inferred insert size” can be used to detect 
structural variants, including: 
 

•  Deletions 

•  Insertions 

•  Inter-chromosomal rearrangements: (Undefined 
insert size)  
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Deletion 
 
 

What is the effect of a deletion 
on inferred insert size? 
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Deletion 
 
 

Reference 
Genome 
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Deletion 
 
 

Reference 
Genome 

Subject 
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Deletion 
 
 

Reference 
Genome 

Subject 
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Deletion 
 
 

Reference 
Genome 

Subject 
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Deletion 
 
 

Reference 
Genome 

Subject 
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Deletion 
 
 

Reference 
Genome 

Subject 
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Deletion 
 
 

Reference 
Genome 

Subject 
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Deletion 
 
 

Reference 
Genome 

Subject 

inferred insert size 
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Deletion 
 
 

Reference 
Genome 

Subject 

inferred insert size 

expected insert size 
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Deletion 

Inferred insert size is > expected value 
Reference 
Genome 

Subject 

expected insert size 

inferred insert size 
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Deletion 
Pairs with larger than 
expected insert size 
are colored red. 
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Deletion 
Note drop in coverage   
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Insert size color scheme 

 
•  Smaller than expected insert size: 

•  Larger than expected insert size: 

•  Pairs on different chromosomes 
 
     Each end colored by chromosome of its mate 
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Rearrangement 

TUMOR 

NORMAL 

CHR 1 CHR 6 
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Rearrangement 

TUMOR 

NORMAL 

Color indicates mate is 
on chromosome 6 

CHR 1 CHR 6 
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Interpreting Pair Orientations 
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Interpreting pair orientations 

Orientation of paired reads can 
reveal structural events, including: 

•  inversions 
•  duplications 
•  translocations 

Orientation is defined in terms of  
•  read strand, left vs right, and  
•  read order, first vs second 
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Inversion 
 
 

Reference 
genome 
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Inversion 
 
 

Reference 
genome 

A B 
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Inversion 
 
 

Reference 
Genome A B 

B A 
Subject 
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Inversion 
 
 

Reference 
Genome A B 

B A 
Subject 



The Broad Institute of MIT and Harvard 
The Broad Institute of MIT and Harvard 

The Broad Institute of MIT and Harvard 

Inversion 
 
 

Reference 
Genome A B 

B A 
Subject 
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Inversion 
 
 

Reference 
Genome A B 

B A 
Subject 
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Inversion 
 
 

Reference 
Genome A B 

B A 
Subject 
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Inversion 
 
 

Reference 
Genome A B 

B A 
Subject 
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Inversion 
 
 

Reference 
Genome A B 

B A 
Subject 
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Inversion 
 
 

Reference 
Genome A B 
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Inversion 
 
 

Reference 
Genome A B 

Anomaly –  
Expected pair orientation is 
inward facing (                 )  
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Inversion 
 
 

Reference 
Genome A B 

“Left” side pair 
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Inversion 
 
 

Reference 
Genome A B 

“Right” side pair 
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Color by pair orientation 
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Inversion 
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Inversion 
 
 

Note drop in coverage 
at breakpoints   
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RNA-Seq 
 
 

•  Examine tissue-specific alternative splicing. 

•  Data:  Illumina BodyMap 2.0  
 
      http://www.illumina.com/science/data_library.ilmn 

Hands-on exercise 
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Before we start: 
Select File > New Session 
to clear IGV window 
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•  Step 1:  Tune settings for RNA. 
 

RNA-Seq Setup 
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RNA-seq alignments 
 
 

Select View > Preferences…  
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RNA-seq alignments 
 
 

Click Alignments tab 
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RNA-seq alignments 
 
 

Select Show junction track 
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RNA-seq alignments 
 
 

Click OK to save changes 
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RNA-seq alignments 
 
 Select Human hg19 

from genome menu 
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RNA-seq alignments 

 
 

Select: 
File > Load from Server…  
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RNA-seq alignments 

 
 

Open the  
Tutorials menu Select  

RNA-Seq (Body Map) 



The Broad Institute of MIT and Harvard 
The Broad Institute of MIT and Harvard 

The Broad Institute of MIT and Harvard 

RNA-seq alignments 
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RNA-seq alignments 
 
 Type SLC25A3 
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RNA-seq alignments 
 
 Click Go 
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RNA-seq alignments 
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RNA-seq alignments 
 
 

If reads are still blue & red from 
the settings for the last exercise, 
then right-click and select  
Color alignments by > no color 
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RNA-seq alignments 
 
 

Heart 

Liver 
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RNA-seq alignments 
 
 

Coverage 
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RNA-seq alignments 
 
 

Junction Coverage 
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RNA-seq alignments 
 
 

Alignments 
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RNA-seq alignments 
 
 

Right-click over 
RefSeq Genes 
track 
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RNA-seq alignments 
 
 

Select Squished 
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RNA-seq alignments 
 
 

Isoforms now 
displayed 
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RNA-seq alignments 
 
 

Click & drag on 
ruler to zoom in 
on first 2 exons 
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RNA-seq alignments 
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RNA-seq alignments 
 
 

Evidence of 
alternative 
splicing 
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Sashimi plot 
 
 Viewing RNA splicing with Sashimi Plots 
 
Reference: Katz Y, Wang ET, Silterra J, Schwartz S, 
Wong B, Mesirov JP, Airoldi EM, Burge, CB. 
Sashimi plots: Quantitative visualization of RNA 
sequencing read alignments.  arXiv:1306.3466 [q-
bio.GN], 2013 
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RNA-seq alignments 
 
 

Right-click over 
alignments 
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RNA-seq alignments 
 
 

Select  
Sashimi Plot 
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RNA-seq alignments 
 
 

Select  
RefSeq Genes 
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RNA-seq alignments 
 
 

Select both 
Heart and Liver 
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RNA-seq alignments 
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RNA-seq alignments 
 
 

A little busy.  
Let’s filter out 
low-count events 
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RNA-seq alignments 
 
 

Right-click anywhere 
over plot 
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RNA-seq alignments 
 
 

Select  
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RNA-seq alignments 
 
 

Enter 20 
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RNA-seq alignments 
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igvtools 
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igvtools 

toTDF 
•  Converts sorted data file to a binary tiled data file (TDF).  
•  Supported file formats: .wig, .cn, .snp, .igv, .gct 

count 
•  Computes average alignment or feature density over a 

specified window size across the genome.  
•  Supported file formats: .sam, .bam, .aligned, .sorted.txt, .bed 

sort 
•  Sorts file by genomic start position.   
•  Supported file formats: .cn, .igv, .sam, .aligned, .bed. 

index 
•  Creates an index file for alignment or feature file.  
•  Supported file formats: .sam, .aligned, .sorted.txt, .bed 

A set of utilities for preparing files for efficient display.  
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igvtools 

•  Can be launched from 
the IGV user interface 
File > Run igvtools… 

•  Or run from the 
command line 
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igvtools toTDF   

The toTDF utility converts large ASCII data files into 
tiled data format (.tdf) files.   
 
TDF files have the following advantages: 

•  Data is indexed for efficient retrieval. 

•  Data is preprocessed for zoomed out views. 

•  TDF files are web friendly – large data files can be 
shared over the web. Only small slices of the file 
are actually transferred as needed. 
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igvtools count 
The count command is used to transform alignment files 
to read density TDF files, e.g. for ChIP-Seq, RNA-Seq, and 
similar alignment counting experiments. 
 
 
 
 
 
 

igvtools 

Alignments Read Density 

TDF format, indexed and 
optimized for fast retrieval at 
multiple resolution scales 

Alignments in bam/sam,  
.aligned, or bed format 
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igvtools sort   

•  Sorts IGV-supported genomic formats by start position.   
•  The index command requires sorted files.  
 
Example:   
igvtools sort  -m 1000000 –t ~/myTmpDir inputFile.sam 
outputFile.sorted.sam 
 
•  Uses combination of memory and disk to handle large files.   
 

-m = maximum # of lines to hold in memory.  When this 
number is exceeded a temporary file is created. 
 
-t = directory used to create temporary files during sorting. 
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igvtools index   

Creates an index file for viewing large files in bed, gff, or vcf formats.   
An index is optional for bed or gff files, but required for vcf files. 
 
An alternative indexing tool is “tabix”.  Tabix both compresses and 
indexes genomic files.  IGV can read either type of index (igvtools or 
tabix).   
 
 
Example:   igvtools index myFeatures.bed    
 
  
 
The index file must remain in the same directory as the input file 
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Computing coverage: igvtools 

 
•  Compute alignment coverage from a BAM file 

using igvtools count command. 
 
 
Data source 
Illumina BodyMap 
 
 
 

Hands-on exercise 



The Broad Institute of MIT and Harvard 
The Broad Institute of MIT and Harvard 

The Broad Institute of MIT and Harvard 

 
 
 Download data files required for this exercise from: 

ftp://ftp.broadinstitute.org/pub/igv/CSH_2013/files.zip 
 
Files included in the zip: 

heart.bodyMap.bam 
heart.bodyMap.bam.bai 
sacCer3.fa (used in next exercise) 
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Computing coverage: igvtools 

 
 
 

Select Tools > Run igvtools… 
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Computing coverage: igvtools 

 
 
 Select Count command 
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Computing coverage: igvtools 

 
 
 

Select input file heart.bodyMap.bam   
Output filename will be filled in 
automatically.  
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Computing coverage: igvtools 

 
 
 

Click Run 
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Computing coverage: igvtools 

 
 
 

Wait for “Done” message 
(should be fast). 
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Computing coverage: igvtools 

 
 
 

Click Close 
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Computing coverage: igvtools 

 
 
 

Select  
File > Load from File… 
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Computing coverage: igvtools 

 
 
 Select heartBodyMap.bam.tdf 

(output from igvtools) 
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Computing coverage: igvtools 

 
 
 

See coverage blip at whole-genome view. 
The BAM file only has data around a single 
gene on chr 12. 
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Computing coverage: igvtools 

 
 
 

Enter SLC25A3 in the 
search box and click Go 
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Computing coverage: igvtools 
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More about reference genomes 

IGV doesn’t host the genome you need? 
 
Use any genome you want, if you have the sequence in 
FASTA format. 
 
Optionally, package genome annotations with the sequence. 
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Loading a genome 
Hands-on exercise 
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Loading a genome 

Select  
Genomes > Load Genome from File… 
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Loading a genome 

Select sacCer3.fa   
(FASTA file for S. cerevisiae) 
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Loading a genome 
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Loading a genome 
Click on a chromosome name or 
use the pulldown menu to jump to 
the chromosome view. 
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Loading a genome 
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Loading a genome 

Click the rightmost “tick” 
to jump to base pair 
resolution 
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Loading a genome 

Confirm that you 
see sequence 
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For further information and help: 
http://www.broadinstitute.org/igv 

http://groups.google.com/group/igv-help  
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