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What is R?

A free software environment
for statistical computing
and graphics

© ® ® RConsole

R version 4.2.1 (2022-86-23) -- "Funny-Looking Kid"
Copyright (C) 2022 The R Foundation for Statistical Computing
Platform: x86_64-apple-darwinl7.® (64-bit)

R is free software and comes with ABSOLUTELY NO WARRANTY.

You are welcome to redistribute it under certain conditions.

Type 'license()' or "licence()' for distribution details.
Natural language suppert but running in an English locale

R is a collaborative preject with many contributors.

Type 'contributors()" for more information and

'citation()' on how to cite R or R packages in publications.

Type 'demo()' for some demos, 'help()' for on-line help, or

'help.start()' for an HTML browser interface to help.

Type 'g()' to quit R.

[R.app GUI 1.79 (B@95) x86_64-apple-darwinl7.@]

> |

Ordination of fuzzy clusters (PCoA)
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Why is R useful?

* Open source
* Data management and manipulation

o Importing data in various formats (like
text files, excel files, etc.)

© Manipulating data (subsetting and
filtering tables, merging, transposing,
etc.)

» Cutting-edge graphical data visualization

* Support for rich statistical simulation and
modeling

* Well established system of packages and

documentation stack overflow

S

* Active development and dedicated
community



Why is R useful?

* Open source

* Data management and manipulation

o Importing data in various formats (like

text files, excel files, etc.) ‘ Stay tuned for our
. : . lab session!
© Manipulating data (subsetting and

filtering tables, merging, transposing,
etc.)

- Cutting-edge graphical data visualization David Barnett

(16t Jan)
* Support for rich statistical simulation and
modeling Rachel Steward
(today)

* Well established system of packages and

documentation _
Next slides —

* Active development and dedicated
community



* The R Project Homepage:
http://www.r-project.org

* Quick R Homepage:
http://www.statmethods.net

* Bioconductor: http://www.bioconductor.org

Wher
| ere to * An Introduction to R (long!): http://cran.r-
earn more project.org/doc/manuals/R-intro.html

about R * Guide to downloading and installing R and
RStudio: https://rstudio-
education.github.io/hopr/starting.html

* R Graph gallery (inspiration for R charts)
https://r-graph-gallery.com

* Google - there are tons of tutorials, guides,
demos, packages and more



R for Biologists

Bioconductor http://bioconductor.org

2,140 packages (05-27-2022):
Variant detection: coding changes,
PolyPhen database
Annotation: pathway analysis,
access GO, KEGG, NCBI and many
others
High-throughput assays: flow
cytometry, mass spec
Transcription factor binding
detection

Phylogenetics and Evolution
http://cran.r-
project.org/web/views/Phylogenetics.html

Ancestral State Reconstruction
Phylogenetic Inference
Trait Evolution

Ecology
http://cran.r-project.org/web/views/
Environmetrics.html

Ordination

Cluster Analysis
Ecological Theory
Population Dynamics
Spatial Data Analysis

DRAWINGHEATMAR

R: ggplot2
Python: seaborn

8 Excel: Conditional Formatting




R Studio

Workspace  History
Load~

Data

diamonds

Values

character (8
goplot[8
Functions

format.plo

Piots Packages

ear Al

Diamond Pricing

Console

Min.




Help in R Studio

Press F1 when the cursor is in the name of the function

@ Rstudio
File Edit Code Vi

Plots Session Build Debug Profile Tools Help

Environment is empty

# Ccolumn names of the dataset
103  coflnames(plantpata)

105 # count the number of rows in your dataset
106 nrow(planmtData)

107

108 # printing whole dataset in the console (usable for small
datasets)
plantpata

row+colnames {base} R Documentation |

Row and Column Names

R is free software and comes with ABSOLUTELY NO WARRANTY.
You are welcome to redistribute it under certain conditions. e
Type ‘Ticense()" or "licence()' for distribution details. Description

Retrieve or set the row or column names of a matrix-

R is a collaborative project with many contributors. v
like object.

Type 'contributors()" for more information and

‘citation()” on how to cite R or R packages in publications.
Usage
Type ‘demo()’ for some demos, 'help()’ for on-1ine help, or
"help.start(}" for an HTML browser interface to help.

Type 'q()’ to quit R.

rownames(x, do.NULL = = °, prefix = "row”
rownames(x) <- value
=

rolnameciv  dn 1100 = - prafiv = "Fal1”
e S

The help
will open
here



rmarkdown : : CHEATSHEET

What is rmarkdown?

.Rmd files - Develop your code and
ideas side-by-side in a single
document. Run code as individual
chunks or as an entire document.

Dynamic Documents - Knit together
plots, tables, and results with
narrative text. Render to a variety of
formats like HTML, PDF, MS Word, or
MS Powerpoint.
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Reproducible Research - Upload, link
to, or attach your report to share.
Anyone can read or run your code to
reproduce your work.

Workflow
€ Open anew Rmdfile in the Rstudio IDE by
going to File > New File > R Markdown.
o Embed code in chunks. Run code by line, by

chunk, or all at once.

Write text and add tables, figures, images, and
citations. Format with Markdown syntax or the
RStudio Visual Markdown Editor.

Set output format(s) and options in the YAML
header. Customize themes or add parameters
to execute or add interactivity with Shiny.

e Save and render the whole document. Kni
periodically to preview your work as you write.

Share your work!

SOURCE EDITOR

autput
henl_docunant

run code ™
chunk(s) show
outline

unent Title set
preview
location

insert
code
chunk

goto
code
chunl

nor Nane!

e 4. Set Output Format(s)
and Options

opts_chunksset echo

13 ¥¢ R Markdown
14

15 This §s an R Markdown document.
16 Markdown is a simple formatting
17 syntax for authoring HTML, POF,
18 and NS Word documents.

:

20- e
[er——

3. Write Text

runall
previous

modify chunks

chunk

options

run
current
chunk

21 summary cars
2

DI

Output created: report.htm

dd/edit
VISUAL EDITOR Stutes

R Markdown
tyle options  insert citations
This is an R Markdown document. Markdown s a simple formarting syntax for

authoring HTML, PDF, and MS Word documents.

Embed Code with knitr

CODE CHUNKS

Surround code chunks with ** &) and """ oruse
Add a chunk label
and/or chunk options inside the curly braces after r.

the Insert Code Chunk button.

***{r chunk-label, include=FALSE}
summary (mtcars)

SET GLOBAL OPTIONS

Set options for the entire document in the first chunk.

"' {r include=FALSE}
knitr::opts_chunk$set(message =

INLINE CODE

Insert ' r <code>" into text sections. Code is evaluated

at render and results appear as text.

“Builtwith *r getRversion() " ->"Built

== posit’

FALSE)

ith4.1.

OPTION
echo

DEFAULT EFFECTS
TRUE  display code in output document

TRUE (display error messages in doc)
FALSE (stop render when error occurs)
run code in chunk
include chunkin doc after running
display code messages in document
display code warnings in document
"asis" (passthrough results)
"hide" (don't display results)
"hold" (put all results below all code)

“left", "right", or "center”

alt text for a figure

figure caption as a character string
prefix for generating figure file paths

error
eval
include
message
warning

results

fig.align
fig.alt
fig.cap
fig.path
fig.width &
fig.height 7
out.width
collapse
comment

"default”
NULL
NULL

“figure/"

plot dimensions in inches

rescales output width, e.g. "75%", "300px™
collapse all sources & output into a single block
prefix for each line of results

files(s) to knit and then include

«child NULL
include or exclude a code chunk when
purl TRUE  axtracting source code with knitr::purl()

See more options and defaults by running str(knitr::opts_chunk$get())

FALSE
g

CCBY SA Posit Software, PBC « info@posit.co « posit.co « Lea more at

@ reporthtml

RENDERED OUTPUT

file path to output document
“Desktapirapieipart Nomi

Open In Browser 4 Publish ~

findin document
publish to
rpubs.com,
shinyapps.io,
Posit Connect

Document Title

Author Name

* R Markd
* Including Plots

R Markdown

This is an R Markdown document, Markdown is a simple formatting
syntax for authoring HTML, PDF, and MS Word documents. For more
details on using R Markdown see http://t m

reload document

wn.rstudio

summary(cars)

»
#
#
#
I
#
#*

@ weosremi a5, 222,711

Insert Citations

Create citations from a bibliography file, a Zotero library,
or from DO references.
BUILD YOUR BIBLIOGRAPHY

Add BibTeX or CSL bibliographies to the YAML header.

title: "My Document"

bibliography: references.bib
link-citations: TRUE

If Zotero is installed locally, your main library will
automatically be available.

Add citations by DOI by searching "from DOI" in the
Insert Citation dialog.

INSERT CITATIONS

« Access the Insert Citations dialog in the Visual Editor
by clicking the @ symbol in the toolbar or by clicking
Insert > Citation.

«+ Add citations with markdown syntax by typing [@cite]
or @cite.

Insert Tables

Output data frames as tables using

kable(data, caption). ‘oo .....,i

A

data <- faithful[l:4, ]

knitr::kable(data,
caption = "Table with kable")

Other table packages include flextable, gt, and kableExtra.

rstudio.com « HTML c!

Write with
Markdown

The syntax on the left renders as the output on the right.

Plain text.
End a line with two spaces to
start a new paragraph.

Also end with a backslash\
to make a new line.

“italics” and **bold**
superscriptA2A fsubscript~2~
~~strikethrough=~
escaped:\"\_\\

endash: ==, emdash: ===
#Header 1

44 Header 2

#4844 Header 6
-unordered list
-item2

- item 2a (indent 1 tab)
-item 2b

1. ordered list

2.item2
- item 2a (indent 1 tab)
-item 2b

<link uri>
[This is a link J(link url)
[This is another link][id).
At the end of the document:
[id]: link url
![Caption](image.png)
or l[Caption][id2]

At the end of the document:
[id2]:image.png
“verbatim code’
multiple lines
of verbatim code

> block quotes

equation: $eAi\pi} + 120§

‘equation block:
$SE=mch2}$$

horizontal rule:

| Ri |

| { 1
112]112]12| 12|
1123123 123 123]
1

L Tabsets
## Results [ tabset}
#4# Plots

tet

#5# Tables

mare text

Plain text.

End a line with two spaces to
start a new paragraph.

Also end with a backslash
to make a new line.

italics and bold
superscript?/subscriptz

escaped: * _\
endash: -, emdash: —

Header 1
Header 2

Header 6
« unordered list
item2

- item Z;(ir\dent 1tab)

- item 2|

1. ordered list

2. item2

« item 2a (indent 1 tab)
b

« item 2

http://www.posit.co/
This is a link
This s another link

Caption.
verbatim code

multiple lines
of verbatim code

block quotes
equation: ¢ + 1 =0
equation block:
E=mc?

horizontal rule:

Default  Center
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Installing packages in R

install.packages("light") library("light")

°*Bioconductor

http://bioconductor.org

W Install once

A7

® BiocManager: :install
(“Package Name”)

b

& \/ Y Use many times

Y C RAN I n Stal I httpS //Cran . r_ I;nages sourced from https://www.wikihow.com/Change-a-Light-Bulb

project.org/web/packages/

® install .packages (“Pa
ckage Name”)

* GitHub install

® devtools::install_gi
thub (“Package Name”)

® remotes::install_git
hub (“Package Name”)




General data structures

Vector - ordered collection of data
vector_ 1 <- c(2, 3, 4, 10)
vector_2 <- c(“potato”, “lemonade”, “avocado”)

Matrix - 2D collection of vectors with same data type
Array - multiple dimension collection of vectors

Dataframe - matrix-like with multiple data types (like an excel table
with text and numbers)

Lists - ordered collection of any objects (can contain also other lists
inside it)

Vector

117

Data Frame

http://venus.ifca.unican.es/Rintro/dataStruct.html



But..

which dataset should we use to do all
these things?



Arabidopsis thaliana mutants
psbol and psbo2




PsbO protein

« Subunit of photosystem II
« Important for water splitting
 Arabidopsis: PsbO1 and PsbO2

STROMA

PsbO  PsbQ

LUMEN

Photosystem I



PsbO protein

« Subunit of photosystem II
« Important for water splitting
 Arabidopsis: PsbO1 and PsbO2

STROMA

Photosystem I



Experimental design

Control Drought Salt stress

- water + NaCl



Measurement — chlorophyl
fluorescence

* Leaf rosette area
* F,/Fy (QY_max) — maximum quantum yield of photosystem Il

WT psbol psho2

Images from FluorCam (PSI) device



Yey!

Let‘s start the practical!

Open the Rstudio server by typing in browser:
<your IP>:8787




No matter, if you have never used R, had trouble
using it, or feel like an absolute R expert...
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